Security Advisory - January 10, 2017

Zscaler protects against 23 new vulnerabilities for Acrobat Reader and Adobe Flash Player.

 

 

Zscaler, working with Microsoft through their MAPP program, has proactively deployed protections for the following 23 vulnerabilities included in the January 2017 Adobe security bulletins. Zscaler will continue to monitor exploits associated with all vulnerabilities in the January release and deploy additional protections as necessary.

APSB17-01 – Security updates available for Acrobat Reader

Adobe has released security updates for Adobe Acrobat and Reader for Windows and Macintosh. These updates address critical vulnerabilities that could potentially allow an attacker to take control of the affected system. 

Severity: Critical

Affected Software

  • Adobe Flash Player Desktop Runtime 23.0.0.207 and earlier
  • Acrobat DC Continuous 15.020.20042 and earlier versions for Windows and Macintosh
  • Acrobat Reader DC Continuous 15.020.20042 and earlier versions for Windows and Macintosh  
  • Acrobat DC Classic 15.006.30244 and earlier versions for Windows and Macintosh
  • Acrobat Reader DC Classic 15.006.30244 and earlier versions for Windows and Macintosh
  • Acrobat XI Desktop 11.0.18 and earlier versions for Windows and Macintosh
  • Reader XI Desktop 11.0.18 and earlier versions for Windows and Macintosh

CVE-2017-2939 – Acrobat Reader Memory Corruption Vulnerability
CVE-2017-2941 – Acrobat Reader Memory Corruption Vulnerability
CVE-2017-2947 – Acrobat Reader Security Bypass Vulnerability
CVE-2017-2948 – Acrobat Reader Buffer Overflow / Underflow Vulnerability
CVE-2017-2949 – Acrobat Reader Heap Overflow Vulnerability
CVE-2017-2950 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2951 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2955 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2956 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2957 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2958 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2961 – Acrobat Reader Use After Free Vulnerability
CVE-2017-2962 – Acrobat Reader Type Confusion Vulnerability
CVE-2017-2966 – Acrobat Reader Heap Overflow Vulnerability
CVE-2017-2967 – Acrobat Reader Memory Corruption Vulnerability

APSB17-02 – Security updates available for Adobe Flash Player

Adobe has released security updates for Adobe Flash Player for Windows, Macintosh, Linux and Chrome OS.  These updates address critical vulnerabilities that could potentially allow an attacker to take control of the affected system.

Severity: Critical 

Affected Software

  • Adobe Flash Player Desktop Runtime 24.0.0.186 and earlier for Windows, Macintosh and Linux
  • Adobe Flash Player for Google Chrome 24.0.0.186 and earlier for Windows, Macintosh, Linux and Chrome OS
  • Adobe Flash Player for Microsoft Edge and Internet Explorer 11 24.0.0.186 and earlier for Windows 10 and 8.1

CVE-2017-2928 – Flash Player Memory Corruption Vulnerability
CVE-2017-2931 – Flash Player Memory Corruption Vulnerability
CVE-2017-2932 – Flash Player Use After Free Vulnerability
CVE-2017-2933 – Flash Player Heap Overflow Vulnerability
CVE-2017-2934 – Flash Player Heap Overflow Vulnerability
CVE-2017-2935 – Flash Player Heap Overflow Vulnerability
CVE-2017-2936 – Flash Player Use After Free Vulnerability
CVE-2017-2937 – Flash Player Use After Free Vulnerability