By: Julien Sobrier

Update To BlackSheep

Data Breach

First of all, thank you very much for all your e-mails and comments! I've tried to answer all. I will give the answer to the most common questions in this blog post.

Install BlackSheep add-on for Firefox 3.x

BlackSheep 1.1 is available. It fixes one issue: with HTTP requests spread over several packets, BlackSheep could detect itself as Firesheep. This is now fixed. To get the new version, go to Tools - Add-ons - Extensions and click on Find Updates. A new version of BlackSheep should be found. if the regular update dopes not work, install it by clicking on this link.

Some users reported the same issues or comments. I'll try to answer them in this post.

Cannot install

BlackSheep cannot be installed in this environment

If you get an error message similar to this one ("BlackSheep" could not be installed because it is not compatible with your Firefox build type (Linux_x86-gcc3). Please contact the author of this item about the problem.) when installing the add-on , this is because your version or Operating System is not compatible with BlackSheep. BlackSheep works on Windows (XP or higher) and MacOSX (10.5 or higher, Intel processor only), and Firefox 3.5 to 3.6.12.

The main reason for these restrictions is that BlackSheep, like Firesheep, contains executables to listen for HTTP traffic. These executables must be compiled for each platform they run on. BlackSheep's executables come straight from the Firesheep code.

However, I am working on extending the platform that can run our plugin. Here are the 2 platforms which should be supported soon:

Firefox 4.0 Beta

In theory, BlackSheep should work on Firefox 4.0. However, I don't have the latest beta installed for testing. If Firefox beta users are ready to test the plugin, I can send them a special package. if enough readers test the plugin successfully on Firefox 4.0 Beta, I will make the official version available for 4.0 Please e-mail me to if you have some time for testing.


Support for Linux is quite a challenge. As mentioned before, the main problem is that there should be a different version for each Linux distribution out there because of the dependencies on multiple libraries.

But support for Linux was number one request I got in the mail today, so I have spend some time on it. Support for Linux should be available on Wednesday. I'll announce it on this blog. Be aware that this will involve some work form the Linux users to get BlackSheep running in their environment.

Javascript error in the preferences menu

JavaScript error in the Preferences menu

"ReferenceError: Cc is not defined". This problem happens mainly for Windows users. Make sure you have Winpcap installed. If not, install it and restart your browser.

Apparently, this also happen for a few Mac users. The main reason is that the back-end is not able to retrieve the list of network interfaces. However, the plugin would most likely work if the interface were to be hard-coded in case of failure. I'm working on a fix for this.

MacOSX and FileVault

If you use FileVault on MacOSX, you might be prompted for a password to run firesheep-backend. See this thread for more information.

Install BlackSheep add-on for Firefox 3.x

Enjoy BlackSheep, and keep reporting any issues or comments.

-- Julien

Learn more about Zscaler.